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Tol aussi tu as connu ce genre de situation ?

Tu ne veux plus revivre ca ?

Alors passe aux outils collaboratifs de versionnage
comme GitLab !

) GitLab

Benjamin Heuclin, Axe transversal TIM, UPR AIDA, Cirad
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Grace a cet outil, tu vas pouvaoir :

« Creer des sauvegardes régulieres de ton travail

Pratique si tu regrettes d’avoir effacé ton dossier de these sur un coup de colére !

o Creer des sauvegardes sur un serveur

Pratique si ton ordi se transforme en barbecue ! &

e Collaborer a plusieurs sur un projet
Pratique pour faire travailler les autres & ta place !

« Partager avec le monde entier ton super travalil
Biennnn pour la science ouverte LY

En plus tu peux utiliser GitLab avec Rstudio !!!
Donc pas d’excuse

s @ cirad 4
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Tout d’abord, dans GitLab, il y a Git !

Git est un logiciel open source de gestion de versions en local
o |l permet de faire des sauvegardes de ton projet sur ton ordi

o Attention ! Siton ordi brule &y { (o, pas de sauvegarde en ligne

o C’est perso donc pas collaboratif

Il faut donc envoyer tes sauvegardes sur un serveur o

GitLab est un logiciel open source de gestion de versions sur serveur

Le Cirad propose ce service : https://qgitlab.cirad.fr/ . Tu vas donc pouvoir :

o Faire des sauvegardes en ligne
o Travailler a plusieurs

o Partager ton travail

&sz‘a%,;%%f écirad _
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https://gitlab.cirad.fr/

Comment se lancer ?

Pour Git :

o |l faut installer Git sur ton PC

o |l faut le configurer

Pour GitLab :

o0 Rien a installer
o Il faut te créer un compte a partir de tes identifiants Cirad

o |l faut configurer la connexion entre ton PC et GitLab

%::%%A%‘f écirad
f-mr
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Installation et configuration de Git

Installation de Git : -> Documentation Cirad

o Pour windows : http://qgit-scm.com/download/win

o0 Pour OSX : http://git-scm.com/download/mac

o Pour linux : https://qit-scm.com/book/fr/v2/D%C3%A9marrage-rapide-Installation-de-Git

Confiqguration de Git (a faire une seule fois) :

Il faut ouvrir un terminal : Depuis Rstudio : Tools > Terminal > New Terminal

o Pour configurer ton nom, il faut rentrer la commande :
git config --global user.name "Prénom Nom"

o Pour configurer ton email :
git config --global user.email "email@cirad.fr"

e @ cirad __ :
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https://gitlab.cirad.fr/cirad/documentation/-/wikis/Installation%20de%20Git%20sur%20Windows
http://git-scm.com/download/win
http://git-scm.com/download/mac
https://git-scm.com/book/fr/v2/D%C3%A9marrage-rapide-Installation-de-Git

Configuration de GitLab

Configuration de la connexion entre ton ordi et le serveur GitLab :
Il faut génerer une clé SSH

Cette étape est a faire une seul fois pour permettre la connexion entre ton ordi et
ton compte GitLab. Pas besoin de la refaire pour chague projet.

o Dans Rstudio :

Va dans : Tools > Global options > Git/SVN > Create RSA Key.

Tu peux lui donner un mot de passe mais t'es pas obligé.

Cette clé sera enregistrée sur ton ordi a I'adresse qui est proposée.
Une fois la clé créée, clique sur “View public key” et copie le contenu.

o0 Ensuite dans GitLab :

Direction : Profile (en haut a droite, le rond avec un bonhomme) > Edit profile > onglet SSH Keys.
Dans la section “Add an SSH key”, colle la clé.

-> Documentation Cirad

gg;%%i%%f écirad .
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https://gitlab.cirad.fr/cirad/documentation/-/wikis/Utilisation%20de%20Git%20avec%20SSH

Comment initialiser Git et GitLab
sur un projet ?

Plusieurs cas de figure existent :

1. Tu veux importer un projet GitLab existant
2. Tu commences un nouveau projet et tu veux le synchroniser avec GitLab

3. Tu veux envoyer sur GitLab un projet que tu as déja sur ton PC

Vidéo -> https://youtu.be/Ly30zu8epwl

%é::t%;%%f écirad __ 9
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https://youtu.be/Ly30zu8epwI

Importer un projet GitLab existant

Tu vas cloner le projet sur ton PC, c’est pas compliqué !

Il faut avoir acces au projet sur GitLab
o Si le projet est public c’est bon
o Sile projet est prive, il faut que 'administrateur te rentre comme collaborateur

Depuis GitLab : Il faut copier 'adresse SSH / FTTPS du projet

. New Project Wizard
Sur ton PC avec Rstudio :
F||e > New project > Back Clone Git Repository
Version Control > Git / 'adresse SSH ici
Repository URL:
I | |
Le nom que tu V_eux Project directory name:

donner au doss@\‘ |

Create project as subdirectory of:

= Browse...

/

Pour sélectionner le chemin ou tu
veux I'enregistrer

lr__t&:lﬁ%;%lg ‘ c I ra d [+ Open in new session Create Project Cafeei

H H H LA A LI AT A~ 1
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2. Nouveau projet connecté a GitLab

Il faut créer un nouveau projet dans GitLab

o Situ n’as pas les droits, il faut demander a un administrateur de te le faire

Maintenant, le projet existe sur GitLab (il est vide), tu peux donc le cloner sur ton

PC en suivant la procédure précéedente

%é::t%;%%f écirad 1
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3. Envoyer sur GitLab un projet que tu
as déja sur ton PC

Il faut que le projet soit associé a un Rproj
0 -> File > New projet... > Existing Directory

Il faut créer un nouveau projet dans GitLab (Attention ! Il faut décocher la case initialisation du README)
o Situ n’as pas les droits, il faut demander a un administrateur de te le faire
0 Copie I'adresse SSH du projet

Ce projet GitLab est vide, il faut maintenant connecter les deux projets (sur GitLab et
. celui sur ton PC) et envoyer le contenu du projet sur ton PC vers GitLab

o Dans un terminal : ouvrir le Rproj puis aller dans -> Tools > Terminal > New Terminal
et rentrer les commandes suivantes une a une :

git init --initial-branch=master

git remote add origin ssh://git@gitlab.cirad.fr:2022/benjamin.heuclin/mon_ projet.git
git add .

git commit -m "Initial commit"

git push -u origin master

Il faut fermer et relancer Rstudio depuis le .Rproj
;‘s;‘:,%,;%‘f écirad g brol—,

‘‘‘‘ Benjamin Heuclin, Axe transversal TIM, UPR AIDA, Cirad

rrrrrrrrrrr



Un nouvel onglet Git est apparu en haut a droite !

Toutes les sauvegardes, exportations, importations, ... vont se faire ici

Fo0 vian Ly o

] Environment History Connection utorial

=]
= piff | | commit = & punl -~ @ Push L {a' - = | master = | (&~

“ | Staged Status “+ Path
Files Plots Packages Help Viewer ———

i o~ ™

s @ cirad
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Avant de commencer,
Deux fichiers importants !

Le « .gitignore » (pas obligatoire)
o Permet de définir des fichiers a ignorer
0 Peut étre édité avec Rstudio

Environment History Connections Git Tutorial =D

S piff | v commit | & | | O £ -

Staged Status “ Path

| Revert...

&) Ignare...

* Rhistory

* Ruserdata
blabla.*
Iblabla.tex

?ﬁ:‘.i.%k%‘éf écirad
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Avant de commencer,
Deux fichiers importants !

Le « README.md » (obligatoire)
o Ce fichier permet de décrire / présenter le projet

o Il est affiché sur la page d’accueil du projet sur GitLab
o Tres important lorsque tu partages ton projet avec le monde entier
o)

C’est du Markdown, tu peux I'éditer avec Rstudio :

-> File > New File > Markdown File

Plus d'info :
o https://en.wikipedia.org/wiki/README

o https://www.makeareadme.com/

0 Guide de référence Markdown : https://commonmark.org/help/

%&:‘:«%A%%f écirad 15
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https://www.markdownguide.org/cheat-sheet/
https://en.wikipedia.org/wiki/README
https://www.makeareadme.com/
https://commonmark.org/help/

Utilisation

Environment History Connections Git  Tutorial .

= pitf | 2| Commit | ¥ -/ # | &L {a > = | master - @~
Staged Status ﬁ’ath
» Prédentation_gitlab_Rstudio.pptx

new_file.

Fichiers modifiés depuis la derniére
sauvegarde (commit)

En local

* “Status” pour voir les fichiers qui ont été
modifiés depuis la derniere sauvegarde
(commit)

WeoRY | « “Stage / Add” pour sélectionner les fichiers
dont tu veux faire une sauvegarde (mise en

)

» “Commit” pour envoyer les fichiers en
zone de transit dans une sauvegarde dans

DEVELOPER A DEVELOPER B le répertoire local
aspuauqu: ‘ d (source de l'image : https://www.qit-tower.com/learn/media/pages/git/ebook/en/command-line/remote-
FRANCAISE C | r(] repositories/introduction/3249033364-1649235984/basic-remote-workflow.pnq)
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https://www.git-tower.com/learn/media/pages/git/ebook/en/command-line/remote-repositories/introduction/3249033364-1649235984/basic-remote-workflow.png

Utilisation

) Environment History Connections Git  Tutorial ———

= Diff il Commit] & Pull - ® Push & {a' - E.—. master = |~
“| Staged Status < Path

Opérations pour communiquer avec le serveur GitLab

0 “Push” pour envoyer ton projet de ton repertoire
local vers GitLab et ainsi pouvoir mettre a jour le

4 . Gltl;ab projet sur GitLab pour tout le monde.
aDn rcu @ CLONE o “Fetch” pour importer la derniere version du projet

depuis GitLab vers ton repertoire local. Il faut

R ensuite mettre a jour ta copie de travail avec la
L =LA - fonction “merge”.

WORKING LOCAL
COPY REPOSITORY
=1

BRI
_____o JUL o N~

. e “Pull” qui combine les opérations “Fetch” et

113 ”
DEVELOPER A DEVELOPER B Merg €

.

o “Merge” pour mettre a jour ta copie de travaill
apres avoir fait un “Fetch”. Il risque d’y avoir des
conflits a résoudre.

azpuauqu: ‘ d (source de l'image : https.//www.git-tower.com/learn/media/pages/qit/ebook/en/command-line/remote-
RANCARE C I ra repositories/introduction/3249033364-1649235984/basic-remote-workflow.png)
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https://www.git-tower.com/learn/media/pages/git/ebook/en/command-line/remote-repositories/introduction/3249033364-1649235984/basic-remote-workflow.png

Utilisation
L’historique (loQ)

® RStudio: Review Changes

Changes History | master - (all commits) -

Subject Author

G oigin/master  origin/HEAD  Suppression d'un fichier heuclin <benjamin.heucin@gmail.com=
modif présentation ppt heuclin <benjamin.heucin@gmail.com=
Maodification du README heuclin <benjamin.heucin@gmail.com=
Premier commit heuclin <benjamin.heucin@gmail.com=

4 (4 Commits 1-4 of 4 boe M

SHA 51af54390be%a%1115de870893ecac082chhd2dd
Author  heuclin <benjamin.heucin@gmail.com=

Date 2022-04-25 15:45

Subject Suppression d'un fichier

Parent  6b0e68bbe500f93626h963609040f179ddfd 194

o Tu peux voir qui a fait des modifications

o Tu peux voir ce qui a été modifié

Search

Date
2022-04-25

2022-04-25
2022-04-25
2022-04-25

& rul

SHA
51af5439

6b0e6bb
3db65365
cfa5d388

o Tu peux récupérer un fichier spécifique dans une précédente sauvegarde

s @ cirad
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Utilisation

o Il est également possible de créer des branches pour travailler en parallele

T Ngn s g o

] Environment History Connections Git Tutorial Creer une bra@f = ]
= piff | ¥/ Commit | ¥ Pul - @ Push | X {3‘ o o= | fmaster | il
“ | Staged Status “+ Path

/

Changer de branche

Files Plots Packages Help Viewer ———

. o~ 1 ™

?ﬁ:‘.i.%k%‘éf écirad
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Ressources

Pour en apprendre plus :
o https://www.jesuisundev.com/comprendre-qgit-en-7-minutes/
o https://thinkr.fr/travailler-avec-git-via-rstudio-et-versionner-son-code/#Git et RStudio

Pour le README :

o https://en.wikipedia.org/wikiiREADME
0 https://www.makeareadme.com/
o 0 Guide de référence Markdown : https://commonmark.org/help/

Documentation Cirad : https://gitlab.cirad.fr/cirad/documentation

Vidéo d’initialisation de projet : https://youtu.be/Ly30zu8epw]

Page GitLab de ce projet :
o https://qgitlab.cirad.fr/lbenjamin.heuclin/intro qit sur rstudio

e @ cirad 20
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https://www.jesuisundev.com/comprendre-git-en-7-minutes/
https://www.jesuisundev.com/comprendre-git-en-7-minutes/
https://thinkr.fr/travailler-avec-git-via-rstudio-et-versionner-son-code/#Git_et_RStudio
https://en.wikipedia.org/wiki/README
https://www.makeareadme.com/
https://commonmark.org/help/
https://gitlab.cirad.fr/cirad/documentation
https://youtu.be/Ly30zu8epwI
https://gitlab.cirad.fr/benjamin.heuclin/intro_git_sur_rstudio

RE PU BLIQUE
FRANCAISE

Mmré

@cirad

C’est finl

Mercl
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